Re: PHP/Oracle/RedHat
| From: | Stanislav Borutsky | Date: | Sun, 04 Jun 2000 15:46:55 +0000 |
| Subject: | Re: PHP/Oracle/RedHat | ||
| References: | 1 2 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-188@lists.php.net to get a copy of this message | ||
> Matthew Green wrote:
> LD_PRELOAD="$ORACLE_HOME/lib/libclntsh.so" httpd -X
Nice. Thanks a lot.
I've checked that (let's say, your ORACLE_HOME is /home/oracle/product/8.1.6)
if you put the following statement as the first line in httpd.conf, this works
as well
as with LD_PRELOAD :
LoadFile /home/oracle/product/8.1.6/lib/libclntsh.so
But this will fail if you'll put the statement at the end of httpd.conf.
Seems like symbols conflict between oracle library and some component of
apache.