RE: [PHP] Re: [PHP-DB] Strangest thing - PHP and Oracle
| From: | Krznaric Michael | Date: | Thu, 24 Aug 2000 13:21:46 +0000 |
| Subject: | RE: [PHP] Re: [PHP-DB] Strangest thing - PHP and Oracle | ||
| Groups: | php.db php.general | ||
| Request: | Send a blank email to php-db+get-2317@lists.php.net to get a copy of this message | ||
Does anyone know where (what file) I can find/see the process that
the ./configure takes to determine the oracle version. If you look at the
script below it finds Oracle-OCI8 support and then it tells me that my
version of oracle is not supported? I'd like to know where to look in order
to find out how it determines the oracle version?
Mike
To Meir,
When i reinstall I always remove the directory and start again. So
unfortunatelly make clean won't help me there.
-----Original Message-----
From: Meir Kriheli [mailto:mksoft@netvision.net.il]
Sent: Thursday, August 24, 2000 6:29 PM
To: Krznaric Michael; 'php-general@lists.php.net';
'php-db@lists.php.net'
Subject: [PHP] Re: [PHP-DB] Strangest thing - PHP and Oracle
On Wed, 23 Aug 2000, Krznaric Michael wrote:
> I'm running php.4 pl2, Apache 1.3.12 and Solaris 7. My Oracle is on a
> different machine than my web server. So I mounted the oracle system on
NFS
> and installed php against oracle 7.3.4 no problem. Now I am trying to
> install with oci8 libraries against oracle 8.1.5 (i mounted a different
> machine on NFS) and the configure fails with the stragnest error.
> Here is a little snippet
> ------------------------------
> checking for Oracle-OCI8 support... yes
> checking Oracle Install-Dir... /cobalt.home1/app/oracle/product/8.1.5/
> +--------------------------------------------------------------------+
> | Notice: |
> | If you encounter <defunc> processes when using a local Oracle-DB |
> | please recompile PHP and specify --enable-sigchild when configuring|
> | (This problem has been reported un Linux using Oracle >= 8.1.5) |
> +--------------------------------------------------------------------+
> checking Oracle version... 7.3
> configure: error: Unsupported Oracle version!
Try to remove the file named config.cache from PHP's dir.
Try "make clean" before configure.
HTH
--
Meir Kriheli
MKsoft computer systems
"There's someone in my head but it's not me" - Pink Floyd
--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net
For additional commands, e-mail: php-general-help@lists.php.net
To contact the list administrators, e-mail: php-list-admin@lists.php.net