Re: Table Full..

From: Date: Mon, 18 Sep 2000 22:13:12 +0000
Subject: Re: Table Full..
References: 1  Groups: php.db 
Request: Send a blank email to php-db+get-2954@lists.php.net to get a copy of this message
From the mysql list: ======================== 18.2.7 The table is full error This error occurs when an in-memory temporary table becomes larger than tmp_table_size bytes. To avoid this problem, you can use the -O tmp_table_size=# option to mysqld to increase the temporary table size, or use the SQL option SQL_BIG_TABLES before you issue the problematic query. See section 7.25 SET OPTION syntax. You can also start mysqld with the --big-tables option. This is exactly the same as using SQL_BIG_TABLES for all queries. ========================== .mike "Hoo Kok Mun" <kokmun@familyhoo.net> wrote : > I have another problem here. > > My table has about 4700 records with about 27 fields. > I have tried the query a few times and it works with up to 1200+ records so > far. > > When I try for all records I have this error:- > SQL Error! The table 'SQLc3c_0' is full > > My Linux is running MySQL 3.22.32 and PHP4.0.1.pl2. > It has 48MB RAM, 400MB free space, swap partition is 16MB. > > > What does this mean and how can I rectify it? > I searched the MySQL Manual again and couldn't find the error message. > > Please advice, really appreciate all hte help that I can get. > > BTW: I have tried - > Suggested by: Brittingham, John > SET OPTION SQL_BIG_TABLES=1 > Done that but still has the same error. > > Suggested by: David Patton > You need to increase the tmp_table_size setting... > Where do I set this variable? > Currently it was set to 1MB.

« previous php.db (#2954) next »