Re: WinNT 4: files become undeleteable when PHP errors. help!

From: Date: Tue, 26 Sep 2000 07:57:21 +0000
Subject: Re: WinNT 4: files become undeleteable when PHP errors. help!
Groups: php.db php.general 
Request: Send a blank email to php-db+get-3080@lists.php.net to get a copy of this message
>1) Often (but not always) when my code generates some sort of PHP error, it >has the effect of somehow "locking" the affected .php file on the server... In fact what happens is that when IIS accesses any file (php or otherwise) it sometimes holds the file open for reading for a while after the file has been served up. Of course you don't normally notice this - but when there has been an error and you want to edit the file, you can't save it. My work around is to use Apache on my development machine - it behaves itself! >2) [This may be related to issue #1) We also have ASP installed on this NT >box. Ever since I installed PHP, ASP has been intermittently dying... This problem is almost certainly caused by the fact that the ISAPI version of php is not at production strength yet - and when it falls over it can brings down other bits of IIS. The work around is to reconfigure IIS to use the cgi version of PHP. Performance will suffer a bit, but your ASP guy will be more impressed! Cheers -- Phil Driscoll Dial Solutions +44 (0)113 294 5112 http://www.dialsolutions.com http://www.dtonline.org

« previous php.db (#3080) next »