Re: A error problem with Oracle

From: Date: Thu, 21 Dec 2000 13:27:26 +0000
Subject: Re: A error problem with Oracle
References: 1 2  Groups: php.db 
Request: Send a blank email to php-db+get-5388@lists.php.net to get a copy of this message
Rouvas Stathis wrote: > Assuming you work with PHP4.xx and Apache, make sure that you do not use > putenv() for Ora related stuff in your PHP scripts. These env vars are > not taken into account. > Correct init params should be set before "/etc/rc.d/apache start" script > executes (or whatever your init script is). > -Stathis. > PS.: I assume that you have already checked that TNSNAMES.ORA still has > correct settings:-) > > "Guridi, Jose" wrote: > > > > It's funny (or tragic) > > > > I was working well with php4 oracle 8.0.6 untill this morning when I red > > your mail. Later I started to get randomly the same error you are reporting. > > The aplication sometimes can sometimes can not connect with oracle and I get > > the same message ORA-12154 TNS could not resolve service name. > > Please if you get some answer to the proble tell me. I will do the same of > > course. > > > > Jose Guridi > > > > -----Mensaje original----- > > De: Kaushik Kumar [mailto:Kaushik.Kumar@bentley.com] > > Enviado el: martes 19 de diciembre de 2000 11:08 > > Para: 'php-db@lists.php.net' > > Asunto: [PHP-DB] A error problem with Oracle > > > > Hello reader, > > I am a web support analyst working for Bentley Systems Inc. We have a > > many projects supported in PHP and are migrating slowly to a java-php > > abstracted applications. Most of our applications run with Oracle(8i) in the > > backend running on WinNT. We have a single RH (red Hat)6.2 server housing > > the SSL and nonSSL services for the customers. Offlate we have noticed that > > the oracle connections fails with > > > > "Warning _oci_open_server: ORA-12154 : TNS could not resolve service name in > > oci.inc.php " > > > > This entire applcation was running without any problem when the load or the > > request was less on the server. Offlate, with higher load, this message is > > being observed the most and we have no clue to resolve this issue. All of > > logons are with "OCIPLogon", I have even tried replacing this to > > "OCILogon". > > Doesnt solve any issue. Could anyone throw more insight to thies problem. > > > > Thanks > > > > Kaushik > > Kaushik Seetharaman Kumar > > Web Support Analyst, ITG > > Bentley Systems Inc. > > kaushik.kumar@bentley.com > > > > -- > > PHP Database Mailing List (http://www.php.net/) > > To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net > > For additional commands, e-mail: php-db-help@lists.php.net > > To contact the list administrators, e-mail: php-list-admin@lists.php.net > > > > -- > > PHP Database Mailing List (http://www.php.net/) > > To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net > > For additional commands, e-mail: php-db-help@lists.php.net > > To contact the list administrators, e-mail: php-list-admin@lists.php.net > > -- > PHP Database Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net > For additional commands, e-mail: php-db-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net You must be add the env var ORACLE_HOME in apachectl script (usually into apache_home/bin) ORACLE_HOME=path_to_oracle_home export ORACLE_HOME Hope this helps -- Luis Castro Mendoza Universidad de Chile Vicerrectoría de Economía y Administración Servicios Tecnológicos de Gestión mailto:lcastro@uchile.cl Phone: 56-2-6782662 Fax: 56-2-6782670

Attachment: [application/x-pkcs7-signature] S/MIME Cryptographic Signature smime.p7s
« previous php.db (#5388) next »