Solid Database Installation

From: Date: Wed, 28 Feb 2001 15:08:29 +0000
Subject: Solid Database Installation
Groups: php.db 
Request: Send a blank email to php-db+get-7019@lists.php.net to get a copy of this message
There have been a number of mails about the SQLParamData error when starting Apache after installing the solid database installation. Here is a list of the actions we had to take to get solid working correctly with PHP 4.04pl1 I hope it saves some time since it cost us a lot ! Solid version is the current linux version 3.5 with glibc2 In the include directlry of solid sqlunix.h change #include <wcstr.h> to #include <stdlib.h> Seems like the call to wcstr.h is an old call. The compilation will then work. In the solid lib directory make symlinks like this: ln –s socl2x35.a libsocl2x35.a ln –s socl2x35.so libsocl2x35.so The standard installation doesnt include these. Not 100% sure they are really needed but we got linker errors. Finally put the path to those libs in LD_LIBRARY_PATH or edit /etc/ld.so.conf (don’t forget to run ldconfig after). Now the PHP problem. After solving these problems you get the SQLParamData error when loading apache. Seems like there is a script error in ./configure There is a test in this file for the existence of the solid files after which there are several echo statements if there is a problem (you can pretty much search for these in the file). On the last echo statement the "else" clause is on the same line and is ignored. Unfortunately the else clause contains the linker statements and is ignored. Hence the error. Putting the else on a new line fixes the problem. You can see if you have this problem when you run configure. You may get the message "Finding Solid Library ..." but no error and nothing after the dots. Hope this helps. David Foster (dfoster@mobilechannel.net)

« previous php.db (#7019) next »