RE: New with MySQL 3.23: Commands out of sync error
| From: | John-Andrew M. Minniti | Date: | Tue, 08 May 2001 05:08:15 +0000 |
| Subject: | RE: New with MySQL 3.23: Commands out of sync error | ||
| References: | 1 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-9162@lists.php.net to get a copy of this message | ||
I just started running MySQL 3.23.37 with php-4.0.5. Anyway, I am randomly
getting this same problem. Probably 90% of the time I don't encounter a
problem, but the other 10% I get the Commands out of sync error. I never
got it before upgrading MySQL.
Any suggestions out there? Maybe in the meantime I should revert to an older
version of MySQL. Perhaps I should use mysql_free_result() in between any
calls, but that seems to be excessive. I'll give it a try in the meantime,
but would love to hear any advice or comments.
Thanks
> -----Original Message-----
> From: Alexander Fordyce [mailto:alex@ax-im.com]
> Sent: Thursday, April 19, 2001 10:10 AM
> To: php-db@lists.php.net
> Subject: New with MySQL 3.23: Commands out of sync error
>
>
> Hi.
>
> I have just run into a strange problem that I'm having a hell
> of a time
> extricating myself from. Here's the story...
>
> Recently, I upgraded to MySQL 3.23.33, mainly to experiment
> with some of the
> new transactional capabilities. But a whole chunk of code
> which had always
> worked perfectly began failing. After adding evil debug code
> to display all
> MySQL error messages, I found that I was getting the
> following error when
> trying to retrieve data from a query result:
>
> "Commands out of sync; You can't run this command now"
>
> I looked up this error on the mysql site, and was taken to
> this page...
> http://www.mysql.com/doc/C/o/Commands_out_of_sync.html
> It mentions the need to use the command mysql_use_result(),
> but php doesn't
> support that. I understand that it's on the "to do" list.
>
> Does anyone else have experience with this problem? At the
> moment, it has
> me completely incapacitated, as moving back to MySQL 3.22 is
> not an option.
> The applications in question are seriously heavy with
> database usage, and
> can't really be slimmed down.
>
> (Another problem which may be related is that I have been getting
> unpredictable results connecting to the database with
> mysql_connect and
> pconnect -- sometimes it fails to connect for no apparent
> reason (about 1
> time in 20, maybe (which is a lot))).
>
> Thanks in advance...
> Alex
>
> - - - - - - - - - - - -
> Alexander Fordyce
> alex@ax-im.com
>
>