ASE serversRe: [PHP-DB] php4 and sybase-ct seg fault

From: Date: Sat, 12 May 2001 13:43:32 +0000
Subject: ASE serversRe: [PHP-DB] php4 and sybase-ct seg fault
References: 1  Groups: php.db 
Request: Send a blank email to php-db+get-9269@lists.php.net to get a copy of this message
Paul Kozlenko wrote: > > Reporting errors to the web page I get; > Warning: Sybase: Server message: Changed database context to 'pcs1prod'. > (severity 10, procedure N/A) in /pcs/pk.php on line 10 > (where line 10 is actually the first line shown here - "sybase_connect") > > Data does come back however after a long period. > Does anybody have any clues I might look for? > > I appreciate any help here from anybody. The problem is that the standard install of php set the "sybct.min_server_severity" to 10, and 10 is definitively not the first level of error reporting for SYBASE servers. For example when you issue a "use mydatabase" SQL statement, you got a message of severity 10 to tell you that the database switching is ok ... The first real level of warning for a SYBASE server is 11 so you'll have to edit your php.ini file and set the correct value to this parametters ! Here is my own configuration : sybase.min_server_severity = 11 ; minimum server message severity to display sybase.min_client_severity = 11 ; minimum client message severity to display Attention apparently these values doni't do anything with PHP4, or there are here for compatibility from older version of PHP : sybase.min_error_severity = 11 ; minimum error severity to display sybase.min_message_severity = 11 ; minimum message severity to display Hope this will help you ! Alain.

« previous php.db (#9269) next »