Re: MySQL Error???
| From: | Dobromir Velev | Date: | Thu, 28 Jun 2001 07:28:13 +0000 |
| Subject: | Re: MySQL Error??? | ||
| Groups: | php.db | ||
| Request: | Send a blank email to php-db+get-9884@lists.php.net to get a copy of this message | ||
Hi,
This error occurs when your auto_increment index field is of type TINYINT.
This field type can accept values form -128 to 127 so you cannot add records
with index value greater than 127.
I recommend you change it to INT(11) UNSIGNED which can accept values from 0
to 4294967295.
If you expect to have more records you may consider using BIGINT type
For more info check the MySQL language reference.
Dobromir Velev
-----Original Message-----
From: Brian Grayless <bgrayless@Premier-Resorts.com>
To: PHP DB list (E-mail) <php-db@lists.php.net>
Date: Thursday, June 28, 2001 9:29 AM
Subject: [PHP-DB] MySQL Error???
>Is anyone familiar with this MySQL error?
>
>"1062: Duplicate entry '127' for key 1"
>I wrote a great bookmark management program that works fine, but everytime
I
>insert bookmarks, I insert somewhere over 120 and I start getting this
>error, and it won't add them anymore. Any suggestions???
>
>Thanks,
>
>B R I A N G R A Y L E S S
> Web Administrator
> Premier Resorts
> www.premier-resorts.com
>
>P: 435-655-4812
>F: 413-618-1518
>
>
>--
>PHP Database Mailing List (http://www.php.net/)
>To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net
>For additional commands, e-mail: php-db-help@lists.php.net
>To contact the list administrators, e-mail: php-list-admin@lists.php.net
>
>