Bug #2357: Apache 1.3.[69] fails with URL http://localhost/php/test.php: "No input file"
| From: | KeijserJJ at logica dot com | Date: | Wed, 22 Sep 1999 17:34:17 +0000 |
| Subject: | Bug #2357: Apache 1.3.[69] fails with URL http://localhost/php/test.php: "No input file" | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-11207@lists.php.net to get a copy of this message | ||
From: KeijserJJ@logica.com
Operating system: Win32 & RedHat 6.0
PHP version: 3.0.12
PHP Bug Type: Installation problem
Bug description: Apache 1.3.[69] fails with URL http://localhost/php/test.php: "No input file"
This is similar to bug reports #1555 and #1919:
When trying something like
http://localhost/php/test.php
on either Apache 1.3.9 + Windows 95 or Apache 1.3.6 + RedHet 6.0 + STANDALONE php I receive only the
message:
No input file specified
However, when I try
http://localhost/php/php.exe/php/test.php
it works fine.
On RedHat 6.0, I've compiled php 3.0.12 straight out of the box using
./configure
./make
./make install
(this gives me the non-redirect version)
Again, I am not using mod_php in this case (since I don't have it on Win32 either), but I am
using the *STANDALONE* version of 'php'.
I've looked in the code, and the same thing is happening on both platforms. This is the
cuplprit:
/* If for some reason the CGI interface is not setting the
PATH_TRANSLATED correctly, request_info.filename is NULL.
We still call php3_fopen_for_parser, because if you set doc_root
or user_dir configuration directives, PATH_INFO is used to construct
the filename as a side effect of php3_fopen_for_parser.
*/
if (cgi || GLOBAL(request_info).filename)
in = php3_fopen_for_parser();
if (cgi && !in) {
if (php3_header()) {
PUTS("No input file specified.\n");
BUT...
PATH_TRANSLATED nor PATH_INFO is set in this case, because the syntax is
".../php/test.php". However, PHP seems to want these variables when run in "CGI
mode" and therefore spits out the erorr message
"No input file specified."
Should this be considered a bug?