Bug #2414: php3_vmailmgr.so refuses to load
| From: | tmcqueen at homefusion dot net | Date: | Thu, 30 Sep 1999 20:36:14 +0000 |
| Subject: | Bug #2414: php3_vmailmgr.so refuses to load | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-11401@lists.php.net to get a copy of this message | ||
From: tmcqueen@homefusion.net
Operating system: RedHat Linux 6.0
PHP version: 3.0.12
PHP Bug Type: Dynamic loading related
Bug description: php3_vmailmgr.so refuses to load
Apache returns the following error in the error_log:
/usr/local/apache/bin/httpd: error in loading shared libraries:
/usr/local/apache/libexec/php3_vmailmgr
.so: undefined symbol: _vm_adduser
My php3.ini file has the following entries:
extension_dir = /usr/local/apache/libexec
extension = php3_vmailmgr.so
The code that causes the error is:
$vdomain = "tld.org";
$vpassword = "somepassword";
vm_adduser($vdomain,$vpassword,"username","foobar");