Bug #2885: can not resolve open64
| From: | pa_wilki at gene dot concordia dot ca | Date: | Wed, 01 Dec 1999 16:23:15 +0000 |
| Subject: | Bug #2885: can not resolve open64 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-13333@lists.php.net to get a copy of this message | ||
From: pa_wilki@gene.concordia.ca
Operating system: Slackware 3.x
PHP version: 3.0.12
PHP Bug Type: MySQL related
Bug description: can not resolve open64
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol 'open64'
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol '__lxstat64'
/csfg/NET/httpdphp/bin/httpd: can't resolve symbol 'fopen64'
Syntax error on line 238 of /csfg/NET/httpdphp/conf/httpd.conf:
Cannot load /csfg/NET/httpdphp/libexec/libphp3.so into server: Unable to resolve symbol
-----
linking php as a dynamic module seems to produce this error. It also appears when compiling php into
apache as a regular module following the instructions given in the manual.
I assume that this has something to so with the filesystem and messages sent to the compiler which
give the linker a problem. The mailing lists were not much help. The only suggestion was to upgrade
mysql to version 3.22.25 ... but I am working with 3.22.27 binary on a pentiumIII.
php does compile just fine, mysql is a binary. Apache compiles with no trouble with the dynamic
module. However make does fail with apache when apache is compiled as a non-dynamic module.
here is the configure line:
./configure --with-apxs=/csfg/NET/httpdphp/bin/apxs \
--with-system-regex \
--with-gd=/usr/local/lib \
--with-mysql=/usr/local/mysql \
--with-zlib=/usr/local/lib \
--with-pdflib=/usr/local/lib \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--with-config-file-path=/csfg/NET/phpconf \
--with-exec-dir=/csfg/NET/php_safe_exec --enable-short-tags=no