Bug #3168: cannot start apache 1.3.9 if mysql is compiled in, but can RESTART successfully
| From: | seth at psy dot au dot dk | Date: | Tue, 11 Jan 2000 04:56:50 +0000 |
| Subject: | Bug #3168: cannot start apache 1.3.9 if mysql is compiled in, but can RESTART successfully | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-14480@lists.php.net to get a copy of this message | ||
From: seth@psy.au.dk
Operating system: Linux 2.2.10
PHP version: 3.0.13
PHP Bug Type: Dynamic loading related
Bug description: cannot start apache 1.3.9 if mysql is compiled in, but can RESTART successfully
Please see Bug id #2187. I have had identical problems as described there.
(and tried to add my comments there, but could not figure out how to do it. Sorry)
Using apache 1.3.9, linux-2.2.10, and php-3.0.13 (or php-4.0b3)
If I compile php-3.0.113 or php-4.0b3 WITHOUT mysql, then
I can repeatedly start and stop apache with no problem (with the php
module being loaded)
If I compile mysql into the php module, then I cannot
start http.
(No errors are reported in the apache log file or on the screen.
I have tried with apachectl, with a /etc/rc.d/init.d/http script, and with
simply httpd. No success.
apachectl configtest and httpd -t reports that the syntax is OK)
I also discovered the "trick" reported in Bug #2187. First comment
out the php module in the apache config file, start httpd, then uncomment
the php module and RESTART the server. And then it works fine,
it is possible to use the mysql database, etc., etc.
So....everything seems to work fine....BUT, if I now STOP the
server, then it is not possible to start again...
(FWIW, I also have a 2.0.36, php-3.0.7, apache-1.3.6 machine running with mysql
with no problems for over a year. )