Suggested minor enhancement to PHP

From: Date: Sun, 30 Jan 2000 18:35:12 +0000
Subject: Suggested minor enhancement to PHP
Groups: php.dev 
Request: Send a blank email to php-dev+get-15054@lists.php.net to get a copy of this message
I would like to make a suggestion for a minor enhancement to PHP. This is to have an appreviated 'if' test much like the '<%+ $varname;%>' statement is an abbreviation for the print statement. For example, rather than having the following line to conditionally include HTML: <% if($is_member) { %> it would be more readable (and more palatable to non-programmers who often work with HTML content) to have a functionally identical statement like the following: <%IF $is_member %> ...accompanied, of course, by '<%ELSE', '<%ELSEIF' and '<%ENDIF' constructs. This is just a general suggestion, there may be better approaches. -Rich

« previous php.dev (#15054) next »