Bug #4104: Failure in starting Apache with Informix

From: Date: Tue, 11 Apr 2000 15:49:56 +0000
Subject: Bug #4104: Failure in starting Apache with Informix
Groups: php.dev 
Request: Send a blank email to php-dev+get-17806@lists.php.net to get a copy of this message
From: regainfo@usa.net Operating system: Linux RedHat 6.1 PHP version: 3.0.15 PHP Bug Type: Installation problem Bug description: Failure in starting Apache with Informix I'm novice to PHP3. Thankyou in advance for the help I need. My goal is to use PHP3 Informix functions on my RedHat 6.1 Linux Box to hook Relational Databases on other systems. My environment is: RedHat 6.1 Kernel 2.2.12 Glibc 2.1.2 Apache 1.3.12 PHP3 3.0.15 Informix Client SDK 2.40.UC1-2 (For Linux 2.2.12 Glibc 2.1.2) I tried both the dynamic Loading of PHP3 via Apache DSO and also the static one, with the same results. I set the Env Variables INFORMIXDIR=/usr/informix (not /usr/informix/lib), PATH=/usr/informix/bin, LD_LIBRARY_PATH="/usr/informix/lib/".(run time). as indicated in php.net. The configure, make and make install of php3 worked fine. Configure line (DSO mode) is: configure --with-apxs="path to apxs bin" \ --with-informix=yes \ --with-mysql \ --with-xml I got the following error at the start of Apache at the line of httpd.conf LoadModule libexec/libphp3.so: "Syntax error on line 207 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/lib/apache/libexec/libphp3.so into server: /usr/lib/apache/libexec/libphp3.so undefined symbol: ifx_module_entry." It sounds like no real compilation of php3 informix driver happened. I noted some lines commented in functions/ifx.ec. The same in the static compilation oh PHP3 with Apache. At the "make" of Apache source I got: "...libphp3.a(internal_functios.o):In function 'getParameterArray' /usr/php3/php-3.015/internal_functions.c: 231 undefined reference to 'ifx_module_entry' collect2:ld returned 1 exit status". Thank again in advance for any kind of help. Remo Ronchitelli regainfo@usa.net

« previous php.dev (#17806) next »