Bug #4211: Apahce fails to load libphp4.so
| From: | tim at tjkern dot com | Date: | Thu, 20 Apr 2000 21:51:34 +0000 |
| Subject: | Bug #4211: Apahce fails to load libphp4.so | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-18086@lists.php.net to get a copy of this message | ||
From: tim@tjkern.com
Operating system: RedHat 6.2 (2.2.14)
PHP version: 3.0.16
PHP Bug Type: Oracle related
Bug description: Apahce fails to load libphp4.so
Hardware:
DELL XPST PIII 500MHz
256M RAM
Software:
Orcale 8.1.5.2
RedHat 6.2
Apache 1.3.12
PHP 4.0 RC1
Env:
$ORACLE_HOME, $ORACLE_SID, standard paths for root
bash shell
apache command line:
./configure --with-prefix=/my/path \
--enable-modules=all \
--enable-shared=max \
--enable-module=rewrite \
--enable-shared=rewrite
...no errors...httpd starts normally...
php command line:
./configure --with-oracle --with-apxs=/path/to --with-track-vars
...compiles/installs without error...
After installation, I try to restart apache and get the error:
Cannot load /path/libphp4.so into server: libclntsh.so.8.0 cannot open shared library or object: No
such file or directory
...it looks like it could be a permission problem...I've seen the problem before with Oracle
installations...it occurs after an Oracle install when trying to run svrmgrl or other apps...the
cure is to run $ORACLE_HOME/install/utl/linux.sh...I tried to apply that fix, but it hosed my Oracle
installation...anyway, if I can help you track this one down, just send me a note...
NOTE: php 3.16 works fine with the Oracle installation
Tim Kern