PHP 4.0 Bug #4437: Apache won't start with php4 and ibm-db2 support
| From: | marco at wildape dot com | Date: | Sat, 13 May 2000 12:31:10 +0000 |
| Subject: | PHP 4.0 Bug #4437: Apache won't start with php4 and ibm-db2 support | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-18695@lists.php.net to get a copy of this message | ||
From: marco@wildape.com
Operating system: Linux (Mandrake 7.0)
PHP version: 4.0 Release Candidate 2
PHP Bug Type: ODBC related
Bug description: Apache won't start with php4 and ibm-db2 support
Hello
I compiled php4-RC2 with:
./configure --with-apxs=/usr/local/apache/bin/apxs --with-ibm-db2
(I also tried it with more options, without better results)
Added a -L/usr/IBMdb2/V6.1/lib in the Makefile
The module compiles correctly. But when I install the module and try to start apache, the apachectl
says it is alright, but there is no httpd started. When I try to start a httpd by hand it also looks
oke, but it stops directly without leaving some childs or an error message, even nothing in the
error-log or /var/log/messages.
When I compile php4 without ibm-db2 everything works correctly.
I'm running on apache-1.3.12.
Please mail me if you have a suggestion, or a possible fix, or a way to debug the code.
Thanks in advance