PHP 4.0 Bug #4445: Apache doesn't start at the first time

From: Date: Mon, 15 May 2000 00:26:04 +0000
Subject: PHP 4.0 Bug #4445: Apache doesn't start at the first time
Groups: php.dev 
Request: Send a blank email to php-dev+get-18739@lists.php.net to get a copy of this message
From: lhadot@atelier.fr Operating system: RedHat 6.2 PHP version: 4.0 Release Candidate 2 PHP Bug Type: Dynamic loading related Bug description: Apache doesn't start at the first time I've used the following to configure Apache 1.3.12 ./configure --prefix=/usr/local/apache --enable-module=so and for PHP4.0 RC2 ./configure --enable-track-vars --enable-dbase --enable-ftp --with-gd=/usr/local --with-jpeg-dir=/usr/local --with-ttf=/usr/local \ --with-imap=/usr/local --with-ldap=/usr/local/ldap --with-mcrypt=/usr/local --with-mysql=/usr/local --with-oracle=/u01/app/oracle/product/8.1.5 \ --with-pdflib=/usr/local/pdflib --with-zlib=/usr/local --with-apxs=/usr/local/apache/bin/apxs --enable-versioning First, I needed to put the exact path to apxs if I would not have this warning : Your /usr/local/apache script is most likely broken. The changes explained in the FAQ have not be needed. Well. When I tried apachectl start for the first time, here is I could see: syntax error on line 208 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: libpdf.so.0: cannot open shared object file: Aucun fichier ou repertoire de ce type ./apachectl start: httpd could not be started I've resolved the error in making a link of the exact lib in /usr/lib I've had the same problem with : libclntsh.so.8.0 libmysqlclient.so.6 libmcrypt-2.2.so.2 Then, Apache announced me that it has been started. But nothing happened. When I put in comment the line LoadModule php4_module libexec/libphp4.so Apache start and it works If I change my httpd.conf, uncomment LoadModule php4_module and restart apache, it works too. Now if I stop it and don't change my httpd.conf (LoadModule not in comment), and start it Apache seems to be started but doesn't work. I'm not sure if it comes from PHP instead of Apache but it could be twice !

« previous php.dev (#18739) next »