PHP 4.0 Bug #4575: PHP4 does not load extension modules unless LD_LIBRARY_PATH is set

From: Date: Wed, 24 May 2000 12:26:11 +0000
Subject: PHP 4.0 Bug #4575: PHP4 does not load extension modules unless LD_LIBRARY_PATH is set
Groups: php.dev 
Request: Send a blank email to php-dev+get-19382@lists.php.net to get a copy of this message
From: blien@ozramp.net.au Operating system: Linux 2.2.14 PHP version: 4.0.0 Release PHP Bug Type: Dynamic loading related Bug description: PHP4 does not load extension modules unless LD_LIBRARY_PATH is set PHP4 does not load extension modules unless LD_LIBRARY_PATH is set (even if extension_dir directive is correct). Funny thing is that dl("extension.so"); works fine without LD_LIBRARY_PATH being set., however apache generates these errors: PHP Fatal error: Unable to load dynamic library 'pgsql.so' - pgsql.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Fatal error: Unable to load dynamic library 'ldap.so' - ldap.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Fatal error: Unable to load dynamic library 'pgsql.so' - pgsql.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Fatal error: Unable to load dynamic library 'ldap.so' - ldap.so: cannot open shared object file: No such file or directory in Unknown on line 0 And yes, apache repeats the errors!? The following is the command used (within .spec to build an rpm, hence the variables). ./configure --prefix=%{_prefix} \ --with-apxs=%{_prefix}/sbin/apxs \ --with-config-file-path=/etc/httpd \ --enable-safe-mode \ --with-exec-dir=%{_prefix}/bin \ --with-system-regex \ --disable-debug \ --with-zlib \ --with-gdbm \ --with-db2 \ --enable-debugger \ --enable-magic-quotes \ --enable-track-vars \ --enable-sysvsem \ --enable-sysvshm \ --enable-track-vars \ --with-xml \ --with-ftp extension_dir = /usr/lib/apache/ ; directory in which the loadable extensions (modules) reside hope this helps.

« previous php.dev (#19382) next »