PHP 4.0 Bug #4679: referenced symbol not found
| From: | jens dot heidenreich at gmx dot net | Date: | Mon, 29 May 2000 20:01:40 +0000 |
| Subject: | PHP 4.0 Bug #4679: referenced symbol not found | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-19709@lists.php.net to get a copy of this message | ||
From: jens.heidenreich@gmx.net
Operating system: Solaris 8
PHP version: 4.0.0 Release
PHP Bug Type: Dynamic loading related
Bug description: referenced symbol not found
Starting Apache 1.3.12 (DSO support) with libphp4.so is failing because of "relocation
error":
$ /opt/apache/sbin/apache_1_3_12ctl configtest
Syntax error on line 231 of /etc/httpd/apache_1_3_12.conf:
Cannot load /opt/apache/libexec/libphp4.so into server: ld.so.1: /opt/apache/sbin/apache_1_3_12:
fatal: relocation error: file /opt/apache/libexec/libphp4.so: symbol ldap_unbind_s: referenced
symbol not found
If i compile WITHOUT ldap support an other relocation error occours for an other support/module (and
so on).
My php config:
./configure \
--prefix=/opt/php4 \
--with-apxs=/opt/apache/sbin/apxs \
--enable-bcmath \
--enable-calendar \
--with-ndbm \
--enable-ftp \
--without-gd \
--with-ldap \
--with-mhash \
--with-mysql=/opt/mysql \
--with-pgsql=/opt/pgsql \
--with-openssl=/opt/openssl \
--with-regex=php \
--enable-sysvsem \
--enable-sysvshm \
--disable-xml \
--with-zlib \
--enable-memory-limit
Compiled in Apache modules (apache -l):
Compiled-in modules:
http_core.c
mod_so.c
suexec: disabled; invalid wrapper /opt/apache/sbin/suexec
Apache Modules (DSO):
LoadModule env_module /opt/apache/libexec/mod_env.so
LoadModule config_log_module /opt/apache/libexec/mod_log_config.so
LoadModule mime_module /opt/apache/libexec/mod_mime.so
LoadModule negotiation_module /opt/apache/libexec/mod_negotiation.so
LoadModule status_module /opt/apache/libexec/mod_status.so
LoadModule includes_module /opt/apache/libexec/mod_include.so
LoadModule autoindex_module /opt/apache/libexec/mod_autoindex.so
LoadModule dir_module /opt/apache/libexec/mod_dir.so
LoadModule cgi_module /opt/apache/libexec/mod_cgi.so
LoadModule asis_module /opt/apache/libexec/mod_asis.so
LoadModule imap_module /opt/apache/libexec/mod_imap.so
LoadModule action_module /opt/apache/libexec/mod_actions.so
LoadModule userdir_module /opt/apache/libexec/mod_userdir.so
LoadModule alias_module /opt/apache/libexec/mod_alias.so
LoadModule access_module /opt/apache/libexec/mod_access.so
LoadModule auth_module /opt/apache/libexec/mod_auth.so
LoadModule setenvif_module /opt/apache/libexec/mod_setenvif.so
LoadModule layout_module /opt/apache/libexec/mod_layout.so
LoadModule php4_module /opt/apache/libexec/libphp4.so