PHP 4.0 Bug #4685: I hope add imap function, so I use DSO, but apache can't start
| From: | master at ncc dot com dot tw | Date: | Tue, 30 May 2000 01:51:38 +0000 |
| Subject: | PHP 4.0 Bug #4685: I hope add imap function, so I use DSO, but apache can't start | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-19722@lists.php.net to get a copy of this message | ||
From: master@ncc.com.tw
Operating system: FreeBSD 3.4
PHP version: 4.0 Latest CVS (30/05/2000)
PHP Bug Type: Dynamic loading related
Bug description: I hope add imap function, so I use DSO, but apache can't start
apache 1.3.12
./configure --prefix=/usr/local/apache --enable-module=most--enable-shared=max
make
make install
php 4.0.0
./configure --with-mysql=/usr/local
--with-apxs=/usr/local/apache/bin/apxs --with-gd=/usr/local
--enable-track-vars --enable-trans-sid --with-ttf --with-imap
--with-zlib
make
make install
it's ok.
but i start apache is error.
/usr/local/apache/bin/apachectl start
Syntax error on line 226 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: Shared
object "lid
./apachectl startssl: httpd could not be started
why?