PHP 4.0 Bug #4712: referenced symbol error when compiling with pgsql
| From: | joed at itsa dot ucsf dot edu | Date: | Tue, 30 May 2000 21:46:47 +0000 |
| Subject: | PHP 4.0 Bug #4712: referenced symbol error when compiling with pgsql | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-19819@lists.php.net to get a copy of this message | ||
From: joed@itsa.ucsf.edu
Operating system: Solaris 8
PHP version: 4.0.0 Release
PHP Bug Type: Installation problem
Bug description: referenced symbol error when compiling with pgsql
Hi,
I'm trying to use this with Postgres7.0 My configure is
./configure --with-pgsql=/usr/local/pgsql \
--without-mysql \
--with-apxs=/usr/local/apache/bin/apxs
I've defined CFLAGS and LD_LIBRARY_PATH as follows:
CFLAGS=-R/usr/local/pgsql/lib -I/usr/local/pgsql/include
LD_LIBRARY_PATH=/usr/local/pgsql/lib
The "make" and "make install" run without any problems, but I can't start
apache. I've checked to ensure /usr/local/apache/libexec/libphp4.so is there, and with the
correct permissions, but I still get this error
pubaffairs# ./apachectl start
Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd:
fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol PQfinish: referenced
symbol not found
./apachectl start: httpd could not be started
P.S. I tried compiling php3.0.16 and got the same error.