PHP 4.0 Bug #4728: Apache reports a syntax error on "LoadModule php4_module"
| From: | ilya at vtrails dot com | Date: | Wed, 31 May 2000 13:46:28 +0000 |
| Subject: | PHP 4.0 Bug #4728: Apache reports a syntax error on "LoadModule php4_module" | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-19882@lists.php.net to get a copy of this message | ||
From: ilya@vtrails.com
Operating system: Linux 2.2.14 i686
PHP version: 4.0.0 Release
PHP Bug Type: Dynamic loading related
Bug description: Apache reports a syntax error on "LoadModule php4_module"
Installation using apxs:
./configure --with-apxs=/usr/local/apache2/bin/apxs --with-sybase=/opt/sybase --disable-debug
make
make install
and than
/usr/local/apache2/bin/apachectl configtest
produces:
[webmaster@segfault conf]# /usr/local/apache2/bin/apachectl configtest
[webmaster@segfault conf]# echo $status
8
and when I replace
LoadModule php4_module libexec/libphp4.so
AddModule mod_php4.c
back with
LoadModule php3_module libexec/libphp3.so
AddModule mod_php3.c
there 's no syntax error.
Apache info:
[webmaster@segfault bin]# ./httpd -v
Server version: Apache/1.3.12 (Unix)
Server built: Apr 6 2000 19:13:10
[webmaster@segfault bin]# ./httpd -l
Compiled-in modules:
http_core.c
mod_so.c