PHP 4.0 Bug #4728 Updated: Apache reports a syntax error on "LoadModule php4_module"
| From: | Bug Database | Date: | Mon, 19 Jun 2000 17:07:45 +0000 |
| Subject: | PHP 4.0 Bug #4728 Updated: Apache reports a syntax error on "LoadModule php4_module" | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-21760@lists.php.net to get a copy of this message | ||
ID: 4728
User Update by: ilya@vtrails.com
Old-Status: Closed
Status: Open
Bug Type: Dynamic loading related
Description: Apache reports a syntax error on "LoadModule php4_module"
You've seen the result of running apachectl with configtest.
If I try to run "apachectl start" it says it has a Syntax Error, but doesn't say what
kind of error.
If the syntax has changed, your script should update the config file correctly (but it didn't
change. I checked both this issue and migration docs).
Anyway, what happens is:
when I tried to use smart scripts that are supposed to install PHP4 for me and restart apache for
me, I got syntax errors etc.
when (after two weeks or so) I tried to run httpd's binary, it segfaulted.
So I guess there are two problems - one with apache script that fails to detect segmentation fault,
and the second is with PHP4.
The log of PHP4 installation process and configure directive are shown here. Maybe you need the core
dump? I can send one to php-dev if you want...
In brief, when httpd tries to perform LoadModule php4_module libexec/libphp4.so, it segfaults.
Full Bug description available at: http://bugs.php.net/version4/?id=4728