PHP 4.0 Bug #5316: PHP stops working after 124 Virtual hosts in httpd.conf
| From: | liam at tiora dot net | Date: | Sat, 01 Jul 2000 19:17:08 +0000 |
| Subject: | PHP 4.0 Bug #5316: PHP stops working after 124 Virtual hosts in httpd.conf | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-23077@lists.php.net to get a copy of this message | ||
From: liam@tiora.net
Operating system: Solaris 2.6 x86
PHP version: 4.0.1
PHP Bug Type: Other
Bug description: PHP stops working after 124 Virtual hosts in httpd.conf
PHP 4.0.1 (and php3 for that matter) stops working after i add in over 124 virtual hosts in my
httpd.conf file. Once i add one more, doesnt matter what, php stops working. Though the rest of
the webserver doesn't have a problem.
I had this problem with php3 also..but i never could figure it out. I tried upgrading to php4 and
in the process figure out the problem had to do with my virutal_hosts.
Once i go past this 124 limit..i get the following error:
(http://www.tiora.net/~chris/test.php)
Warning: Failed opening '/home/chris/public_html/test.php' for inclusion
(include_path='') in Unknown on line 0
however...
http://www.tiora.net:8080/~chris/test.php
works fine.
This is the *same* httpd binary and same httpd.conf with just not as many virtual hosts.
I am running the following:
Apache 1.3.12 with the following modules
PHP 4.0.1
mod_perl 1.24
We have about 140 virtual hosts in our HTTPD.CONF file.
(see http://www.tiora.net:8080/~chris/test.php for
more information about my php setup).
Please feel free to contact me if you need more information.
Thanks in advance!
liam