Re: PHP 4.0 Bug #5488: libphp4.so unable to find libmysqlclient.so.6

From: Date: Sun, 09 Jul 2000 05:32:24 +0000
Subject: Re: PHP 4.0 Bug #5488: libphp4.so unable to find libmysqlclient.so.6
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-23896@lists.php.net to get a copy of this message
That's a case of a misconfigured /etc/ld.so.conf. Edit /etc/ld.so.conf and add /usr/local/mysql/lib to it, and then run ldconfig. After that, restart apache. This should correct your problem. Chris On 10 Jul 2000 nsfmc@yahoo.com wrote: > From: nsfmc@yahoo.com > Operating system: RedHat Linux 6.2 (Zoot) > PHP version: 4.0.1pl2 > PHP Bug Type: MySQL related > Bug description: libphp4.so unable to find libmysqlclient.so.6 > > I installed mysql in /usr/local/mysql/ > EVERYTHING went well in the ./configure and the make and make install. No errors to be found, > however, when i restart apache i get the following error: > > Cannot load /usr/local/apache/libexec/libphp4.so into server: libmysqlclient.so.6: cannot open > shared object file: No such file or directory > > What i would like to know is, WHERE is libphp4.so looking for libmysqlclient if i configured > php with > --with-mysql=/usr/local/mysql > > But, if i configure php with > --with-mysql > WITHOUT a directory, everything works just fine. Should i be worried or as John Romero would > say, just Suck It Down (curiously, not trademarked i think). > > --nsfmc > > > -- > PHP Development Mailing List <http://www.php.net/> > To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net > For additional commands, e-mail: php-dev-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net > >

« previous php.dev (#23896) next »