PHP 4.0 Bug #5689: apache fails with mysql-supported php
| From: | rakeshc at hotmail dot com | Date: | Thu, 20 Jul 2000 05:50:07 +0000 |
| Subject: | PHP 4.0 Bug #5689: apache fails with mysql-supported php | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-25178@lists.php.net to get a copy of this message | ||
From: rakeshc@hotmail.com
Operating system: Redhat linux 6.2
PHP version: Earlier? Upgrade first!
PHP Bug Type: Installation problem
Bug description: apache fails with mysql-supported php
I am trying to install php using the 3.0.16 source on php.net. I am doing this since the Redhat rpm
for php does not come with in-built MySQL support. I am using the simplest switches for configure:
--with-apxs=/usr/sbin/apxs --with-mysql --with-xml \
--with-config-file-path=/etc/httpd \
--enable-track-vars
All the steps (configure, make and make install) were completed with NO error messages. The
libphp3.so file was created and I moved the php3.ini file to /etc/httpd. I also changed the
httpd.conf file like mentioned in documentation.
BUT when I try to restart apache using /etc/rc.d/init.d/httpd, it fails although the message for
starting httpd is [OK]. When I re-install the Redhat rpm, everything is hunky-dory again. What is
happening?
I am posting this bug only after 3 sleepless nights and failure to get help from all the
documentation and newsgroups. Kindly email me if you can help me out.
Thanks.