PHP 4.0 Bug #5773: ISAPI filter won't function with long directory name
| From: | steve at teamITS dot com | Date: | Mon, 24 Jul 2000 22:58:43 +0000 |
| Subject: | PHP 4.0 Bug #5773: ISAPI filter won't function with long directory name | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-25906@lists.php.net to get a copy of this message | ||
From: steve@teamITS.com
Operating system: Windows NT 4.0 SP6a
PHP version: 4.0.1pl2
PHP Bug Type: Installation problem
Bug description: ISAPI filter won't function with long directory name
If the PHP files are copied to a folder such as "D:\Program Files\PHP" the ISAPI filter
will not load. After copying the files to "D:\inetsrv\PHP" it loads. During the error
condition the server returns error 500 (internal server error) for PHP pages. The CGI module loads
both ways, with the long name in the configuration field as:
"D:\Program Files\PHP\php.exe" %s %s
(however using quotes doesn't work for ISAPI...in fact without them MMC won't let you exit
the dialog, claiming an invalid path).