PHP 4.0 Bug #5902 Updated: Apache(apxs w/ php) fails to start
| From: | Bug Database | Date: | Fri, 04 Aug 2000 16:41:39 +0000 |
| Subject: | PHP 4.0 Bug #5902 Updated: Apache(apxs w/ php) fails to start | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-27724@lists.php.net to get a copy of this message | ||
ID: 5902
Updated by: rasmus
Reported By: mathison@sara.cpb.org
Status: Closed
Bug Type: Reproduceable crash
Assigned To:
Comments:
This is due to a glibc-2.1.x bug which prevents a binary (httpd in this case) from loading a shared
library (libphp4.so) when the binary has not been linked against pthreads and the library has. So,
either link httpd against pthreads, or get yourself a version of the libmysqlclient.so library which
is not linked against pthreads. Either compile MySQL from source since by default it does not
created a pthreads-linked client library, or rebuild from the SRPM but edit the SPEC file and remove
the switch that turns on the threaded client library.
Full Bug description available at: http://bugs.php.net/?id=5902