PHP 4.0 Bug #6100: failed to use both mod_php3 and mod_php4
| From: | udo dot rader at profile dot co dot at | Date: | Fri, 11 Aug 2000 06:27:21 +0000 |
| Subject: | PHP 4.0 Bug #6100: failed to use both mod_php3 and mod_php4 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-28467@lists.php.net to get a copy of this message | ||
From: udo.rader@profile.co.at
Operating system: suse linux 6.2
PHP version: 4.0.1pl2
PHP Bug Type: Installation problem
Bug description: failed to use both mod_php3 and mod_php4
for various reasons i need both mod_php3 and mod_php4 loaded into my apache 1.3.9 as dso's.
after recompiling and reinstalling apache using mod_so now, recompiling and reinstalling php3 to use
apxs and versioning and after all compiling and installing php4 i get the following strange error
messages in my httpd.error_log:
-------CUT----------
PHP Warning: Function registration failed - duplicate name - define in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - defined in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - each in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strlen in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcasecmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - error_reporting in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - leak in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - function_exists in Unknown on line 0
PHP Warning: Basic Functions: Unable to register functions, unable to load in Unknown on line 0
-------CUT----------
obviously php4 rejects living with php3 ...
i am able to use the php3 dso without problems, if i outcomment the loadModule command for php4 in
httpd.conf, the same applies for the php4 dso counterwise.
on the other hand the php4 only dso usage results in a "Zero Sized Reply" if i use any
technology other than php4 (eg. mod_perl).
stats:
OS: suse linux 6.2
kernel: 2.2.10