Re: Build Problem with latest CVS source under OpenBSD 2.7
| From: | Brendan W. McAdams | Date: | Sun, 13 Aug 2000 19:55:27 +0000 |
| Subject: | Re: Build Problem with latest CVS source under OpenBSD 2.7 | ||
| References: | 1 | Groups: | php.dev php.qa |
| Request: | Send a blank email to php-dev+get-28768@lists.php.net to get a copy of this message | ||
I havent' had time to dissect the problem yet, but I use a perl script to
sync source and buildconf...same script under Linux (slack 2.7) works
perfectly.
I'm wodnering about general issues with OpenBSD as I've had problems
building mySQL under OpenBSD before as well (as have several friends)...
We should resolve this issue though as best we can.
On Sun, 13 Aug 2000, Zak Greant wrote:
> Both Brendan and I have encountered the same problems trying to build the
> latest CVS source on OpenBSD 2.7 (i386)
>
> We both grab the freshest source from php.net, grab Zend and TSRM from
> zend.com and place it in the php4 directory.
>
> When we run configure in the main directory, we get this error:
> ./configure[2332]: syntax error: `./scripts/config-stubs' unexpected
>
> Can anyone provide guidance on this problem?
>
> Here is my amateurish attempt to determine what is going on...
>
> This line is where configure attempts to include the config.m4 scripts for
> the server apis.
>
> The exact line reads:
> esyscmd(./scripts/config-stubs sapi)
>
> AFAIK this line is correct (however, I did not even know that m4 existed
> til about 1/2 hour ago - so I am likely to be wrong :)
>
> I ran the script directly, commented out 2332 and added what it should
> output...
>
> This turned out to be:
> sinclude(./sapi/aolserver/config.m4)
> sinclude(./sapi/apache/config.m4)
> sinclude(./sapi/cgi/config.m4)
> sinclude(./sapi/isapi/config.m4)
> sinclude(./sapi/nsapi/config.m4)
> sinclude(./sapi/phttpd/config.m4)
> sinclude(./sapi/pi3web/config.m4)
> sinclude(./sapi/roxen/config.m4)
> sinclude(./sapi/servlet/config.m4)
> sinclude(./sapi/thttpd/config.m4)
>
> I continued to get an error when running configure - so I tried running one
> of the scripts directly and received a permission denied message. After
> modifying my permissions, I re-ran configure and received this error
> message:
>
> ./configure[2333]: syntax error: `./sapi/aolserver/config.m4' unexpected
>
> So, err... does anyone have any pointers for me? Grepping through the m4
> docs did not turn up any references to 'unexcpected'
>
> The fact that I received the same error message leads me to believe that
> either:
> - there is a syntax error above 2332 that I have not detected
> - or there is a problem with the config.m4 files
> - or there is a problem with m4 on openbsd...
> - an insect broke wind in upper Tunisia, disturbing the delicate balance
> of the universe and breaking the PHP build process in OpenBSD ;)
>
> - Zak
>
>
>
> --
> PHP Quality Assurance Mailing List <http://www.php.net/>
> To unsubscribe, e-mail: php-qa-unsubscribe@lists.php.net
> For additional commands, e-mail: php-qa-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>
>