Re: PHP 4.0 Bug #6147: Error "unresolved symbol: mysql_module_entry" with SSL
| From: | Jani Taskinen | Date: | Mon, 14 Aug 2000 15:08:40 +0000 |
| Subject: | Re: PHP 4.0 Bug #6147: Error "unresolved symbol: mysql_module_entry" with SSL | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-28824@lists.php.net to get a copy of this message | ||
> Using mysql-3.20.32a-3 RPMs. Using Apache 1.3.12 with mod_ssl-2.6.5 and
> openssl-0.9.5. No errors when compiling/installing PHP.
> On running "apachectl startssl" the error "unresolved
> symbol: mysql_module_entry" is returned. When running "apachectl
> start", no error is returned.
This is yet another bug. I noticed this myself when compiling an
ssl-enabled apache using mod_ssl.
Clip from my original httpd.conf:
<IfDefine SSL>
LoadModule php4_module libexec/libphp4.so
LoadModule ssl_module libexec/libssl.so
</IfDefine>
So if apache is started with ./apachectl start the php-module isn't loaded
at all. So the script which adds that module info into httpd.conf is broken.
But I don't know what's wrong with the bug reporter's compile though.
Maybe too old mysql-rpm?
--Jani