PHP 4.0 Bug #6072 Updated: ldap library missing from libphp4.so - shows up when apache is started.

From: Date: Mon, 14 Aug 2000 22:50:04 +0000
Subject: PHP 4.0 Bug #6072 Updated: ldap library missing from libphp4.so - shows up when apache is started.
Groups: php.dev 
Request: Send a blank email to php-dev+get-28866@lists.php.net to get a copy of this message
ID: 6072 User Update by: karen.turner@opus.co.nz Status: Feedback Bug Type: Installation problem Description: ldap library missing from libphp4.so - shows up when apache is started. Hi I have just untarred php src and re-built using ./configure --with-apxs=/opt/serv/sbin/apxs --with-ldap=/opt/serv The ldap library is still missed. ldd libphp4.so libgdbm.so => /opt/gnu/lib/libgdbm.so libpam.so.1 => /usr/dt/lib/libpam.so.1 libdl.so.1 => /usr/lib/libdl.so.1 libresolv.so.2 => /usr/lib/libresolv.so.2 libm.so.1 => /usr/lib/libm.so.1 libnsl.so.1 => /usr/lib/libnsl.so.1 libsocket.so.1 => /usr/lib/libsocket.so.1 libc.so.1 => /usr/lib/libc.so.1 libmp.so.2 => /usr/lib/libmp.so.2 Starting the Apache Web Server. Syntax error on line 228 of /opt/serv/etc/httpd.conf: Cannot load /opt/serv/libexec/libphp4.so into server: ld.so.1: /opt/serv/sbin/httpd: fatal: relocation error: file /opt/serv/libexec/libphp4.so: symbol ldap_unbind_s: referenced symbol not found Ldap is still missing from libs/libphp4.la I was trying to work out at what point the ldap library was being missed. Which was how I noticed it was missing from the la file, where as mysql etc were listed. But I wasn't quite sure of where it should be appearing and at what point it had gone missing. My version of ldap will be upgraded hopefully soon. Thanks Karen Full Bug description available at: http://bugs.php.net/?id=6072

« previous php.dev (#28866) next »