Re: PHP 4.0 Bug #5109 Updated: Failed to build dynamic Apache module
| From: | Morten Rønseth | Date: | Mon, 21 Aug 2000 06:05:48 +0000 |
| Subject: | Re: PHP 4.0 Bug #5109 Updated: Failed to build dynamic Apache module | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-30015@lists.php.net to get a copy of this message | ||
on 8/20/00 9:59 AM, Bug Database at php-dev@lists.php.net wrote:
> ID: 5109
> Updated by: sniper
> Reported By: morten.ronseth@coil.no
> Status: Feedback
> Bug Type: Dynamic loading related
> Assigned To:
> Comments:
>
> Does this problem still persist with more recent version of php (from CVS or
> http://snaps.php.net) ??
>
> And try adding the full path for apxs into --with-apxs
>
> --Jani
>
> Full Bug description available at: http://bugs.php.net/?id=5109
>
Hi,
No, this pretty much works OK now.
I should probably register this next bit through the proper channels but
I'll include it here for you to see. The following is my mailing to the
MacOSX Admin News group, 10. aug.:
-----
Hi,
Just compiled and installed PHP 4.0.2pl2 and everything went smooth.
However, when I do an 'apachectl configtest' it tells my that php module
isn't compatible with the Apache version and hence apache won't start. I
tried changing major & minor magic numbers in
'/System/Library/Frameworks/Apache.framework/Versions/1.3/Headers/ap_mmn.h'
but I still get the same error.
I'm running osx server 1.2, Apache 1.3.9
Anybody experienced this before and if so, is there any solution?
----
It appears that this is a problem with MacOS X Server 1.2 as others have
succesfully compiled PHP 4.0.2pl2 under 1.0{.2}
As I said, I'll register this through the proper channel also.
Cheers,
-Morten
---------------------------------------------------------------
Coil AS http://www.coil.no
Morten Lerskau Rønseth mailto:morten.ronseth@coil.no
Karenslyst Allé 16d Tlf.: (47) 2254 1820
0278 Oslo Fax : (47) 2254 1821
Norway Mob.: (47) 9343 4357
ICQ : 25163080