PHP 4.0 Bug #6307: Load PHP as DSO failed
| From: | yale_yu at yahoo dot com | Date: | Wed, 23 Aug 2000 07:56:25 +0000 |
| Subject: | PHP 4.0 Bug #6307: Load PHP as DSO failed | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-30284@lists.php.net to get a copy of this message | ||
From: yale_yu@yahoo.com
Operating system: Solaris 7
PHP version: 4.0.1pl2
PHP Bug Type: Dynamic loading related
Bug description: Load PHP as DSO failed
My configure line is as simple as:
./configure --with-apxs=/usr/local/apache/bin/apxs --without-mysql
configure, make, make install are all successful, but apachectl start returned (line 207 is
'LoadModule php4_module libexec/libphp4.so'):
Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd:
fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol ap_block_alarms:
referenced symbol not found
/usr/local/apache/bin/apachectl start: httpd could not be started
It seems php building referenced some apache function, but didn't know how to find it.