Re: PHP 4.0 Bug #4639 Updated: Unable to build a working DSO
| From: | Juhana Enqvist | Date: | Thu, 24 Aug 2000 09:58:27 +0000 |
| Subject: | Re: PHP 4.0 Bug #4639 Updated: Unable to build a working DSO | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-30488@lists.php.net to get a copy of this message | ||
Bug Database wrote:
>
> ID: 4639
> Updated by: sniper
> Reported By: juhana.enqvist@comptel.com
> Status: Feedback
> Bug Type: Compile Failure
> Assigned To:
> Comments:
>
> Is this anyways related to bug #4637 ??
>
> And again, have you tried any recent versions of PHP4 whether the problem persists or not?
>
> --Jani
>
> Full Bug description available at: http://bugs.php.net/?id=4639
More info:
The problem seems to be that the Apache expects all shared objects to be named
with suffix .so, even if the native suffix of the host is something else (like
.sl in HP-UX). I managed install the module with apxs by renaming the libphp4.sl
to libphp4.so and manually running the apxs. But when trying to start apache I
get:
/usr/lib/dld.sl: Unresolved symbol: __umoddi3 (code) from
/projects/finnet/common/apache-1.3.12-HPUX10.20/libexec/libphp4.so
--
Juhana Enqvist Juhana.Enqvist@comptel.com
Comptel Oyj Plc http://www.comptel.com
MDS Finnet / Ru4 211 tel. +358-9-700 11 843
Ruoholahdenkatu 4, 00180 Helsinki, Finland fax +358-9-700 11 375