PHP 4.0 Bug #6397: Cannot start Apache due to _dl_default_scope
| From: | michael at intellnet dot net dot uk | Date: | Mon, 28 Aug 2000 11:52:23 +0000 |
| Subject: | PHP 4.0 Bug #6397: Cannot start Apache due to _dl_default_scope | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-30948@lists.php.net to get a copy of this message | ||
From: michael@intellnet.net.uk
Operating system: Debian Linux 2.2.17
PHP version: 4.0.1pl2
PHP Bug Type: Dynamic loading related
Bug description: Cannot start Apache due to _dl_default_scope
Compiling php as a loadable module:
./configure --with-mysql --with-apxs
System compiles fine.
When attempting to re-start apache with the new module:
Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib/apache/1.3/libphp4.so: undefined
symbol: _dl_default_scope.
As static, php compiles fine but apache compile drops out :
/usr/lib/libdl.a(dlsym.o): In function `doit.2':
dlsym.o(.text+0x22): undefined reference to `_dl_default_scope'
dlsym.o(.text+0x4c): undefined reference to `_dl_default_scope'
make[2]: *** [target_static] Error 1
make[2]: Leaving directory `/usr/apache_1.3.12/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/apache_1.3.12'
make: *** [build] Error 2
Bit stumped, even tried previous versions of php4 to no avail.
With thanks
Michael