PHP, 4 Apache 1.3.9 DSO, Solaris 2.7
| From: | Hans Kind | Date: | Fri, 01 Sep 2000 10:00:52 +0000 |
| Subject: | PHP, 4 Apache 1.3.9 DSO, Solaris 2.7 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-31554@lists.php.net to get a copy of this message | ||
Hi,
I keep getting the following error when I start Apache 1.3.9 PHP 4 DSO. No problems reported during configure and make.
Syntax error on line 233 of /opt2/kindserv/httpd/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /opt2/kindserv/httpd/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol php_regcomp: referenced symbol not found
I search all the available mailin gliost, and noticed a cpuple of other that are having the same problem. Tried all the sugested solution, non worked.
gcc version 2.95.2
Solaris 2.7
Apache 1.3.9
Configured with:
./configure --with-mysql=/opt/software/mysql -with-apxs=/usr/local/apache/bin/apxs --enable-track-vars --with-regex --with-imap=/usr/local --enable-versioning --enable-libgcc
Also added:
CFLAGS="-L/usr/local/lib/gcc-lib/sparc-sun-solaris2.7/2.95.2/libgcc" LIBS="-lgcc"
rgds
Hans Kind