PHP 4.0 Bug #6490: Apache startup fails with undefined symbol in libphp4.so

From: Date: Fri, 01 Sep 2000 18:24:48 +0000
Subject: PHP 4.0 Bug #6490: Apache startup fails with undefined symbol in libphp4.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-31611@lists.php.net to get a copy of this message
From: dp@recycled.net Operating system: NetBSD/i386 1.4.2 PHP version: 4.0.2 PHP Bug Type: Dynamic loading related Bug description: Apache startup fails with undefined symbol in libphp4.so PHP 4.0.2 configured: ./configure --with-apxs=/www/apache/bin/apxs --with-ldap=/usr/local --with-imap=/usr/local --with-pgsql=/apps/pgsql Versions of called libraries/includes: OpenLDAP: 1.2.11, IMAP: UW-IMAP 4.7c2, PostgreSQL: 7.0.2, Apache: 1.3.12. # /www/apache/bin/apachectl configtest (or start) /usr/libexec/ld.so: Undefined symbol "_unixdriver" in httpd:/www/apache/libexec/libphp4.so There are other similar mentions of this in the bug database; one suggestion was to include the necessary -L/-l/-I calls in Apache as well as in PHP; I tried this and encountered the same results. Any help appreciated; it looks like this has come up before, and hopefully has since been resolved.

« previous php.dev (#31611) next »