PHP 4.0 Bug #6530 Updated: undefined symbol: gss_mech_krb5

From: Date: Mon, 04 Sep 2000 15:33:58 +0000
Subject: PHP 4.0 Bug #6530 Updated: undefined symbol: gss_mech_krb5
Groups: php.dev 
Request: Send a blank email to php-dev+get-31940@lists.php.net to get a copy of this message
ID: 6530 Updated by: eriksson Reported By: flavour@partyvibe.com Status: Feedback Bug Type: Dynamic loading related Assigned To: Comments: This error is caused by kerberos dependeny in the imap rpm:s. It is possible to get rid of this dependency by downloading the source rpm and modifying this line in /usr/src/redhat/SPECS/imap.spec: %define gssapi %(test -r /usr/kerberos/lib/libkrb5.a && echo 1 || echo 0) to this line %define gssapi %(echo 0) Then creating the rpms: rpm -bb /usr/src/redhat/SPECS/imap.spec Uninstall old rpms: rpm -e imap imap-devel Install new rpms: rpm -ivh /usr/src/redhat/RPMS/i386/imap*.rpm Previous Comments: [2000-09-04 11:15:25] sniper@php.net So --with-kerberos doesn't help? --Jani --------------------------------------------------------------------------- [2000-09-04 10:08:12] flavour@partyvibe.com ./configure --with-apxs=/usr/sbin/apxs --enable-debug=no --enable-track-vars=yes --enable-magic-quotes --enable-bcmath=yes --enable-memory-limit=yes --with-mysql=/usr --with-imap --without-kerberos --with-ldap=/usr --with-ttf --with-zlib --with-gd --with-gdbm Configure works fine Loading fails on --with-imap (I've tested around this) I've tried to enable & disable kerberos, it fails either way. RedHat Linux v6.2 Apache-1.3.12 imap-4.7-7 krb5-configs-1.1.1-9 krb5-devel-1.1.1-9 krb5-libs-1.1.1-9 --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=6530

« previous php.dev (#31940) next »