PHP 4.0 Bug #5536 Updated: Iplanet (Netscape) fails to load when trying to load PHP

From: Date: Tue, 05 Sep 2000 03:23:03 +0000
Subject: PHP 4.0 Bug #5536 Updated: Iplanet (Netscape) fails to load when trying to load PHP
Groups: php.dev 
Request: Send a blank email to php-dev+get-32065@lists.php.net to get a copy of this message
ID: 5536 Updated by: sniper Reported By: lkstitch@ucalgary.ca Status: Closed Bug Type: Installation problem Assigned To: Comments: User feedback: I gave up and switched to using jsp and servlets. -- Closed. --Jani Previous Comments: [2000-09-04 20:54:31] sniper@php.net Is this still happening with using php4.0.2 ? --Jani --------------------------------------------------------------------------- [2000-07-12 16:37:04] lkstitch@ucalgary.ca System is AIX 4.3 with iPlanet 4.0 and mysql (gcc 2.9.5.2). Configured PHP with: ./configure --with-mysql=/zd1/local/mysql/mysql-3.22.32 --with-nsapi=/usr/netscape/server4 --enable-libgcc --enable-experimental-zts Compiled fine, ran make install, installed fine. Added lines to obj.conf and tried to startup server and I get: [https-macon.acs.ucalgary.ca]: start failed. (2: unknown early startup error) [https-macon.acs.ucalgary.ca]: conf_init: Error running init function load-modules: dlopen of /usr/netscape/server4/bin/libphp4.so failed 0509-023 Symbol __builtin_delete in /usr/netscape/server4/bin/libphp4.so is not defined. [https-macon.acs.ucalgary.ca]: 0509-023 Symbol __rtti_si in /usr/netscape/server4/bin/libphp4.so is not defined. [https-macon.acs.ucalgary.ca]: 0509-023 Symbol __rtti_user in /usr/netscape/server4/bin/libphp4.so is not defined.) [https-macon.acs.ucalgary.ca]: server exit: status 1 From reading the README.Zeus file in the php dist it describes a problem simular to this but I don't know how to fix it.. I believe those symbols come from libgcc.a, Any ideas? --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=5536

« previous php.dev (#32065) next »