PHP 4.0 Bug #6556: Apache can't start with pdflib support
| From: | saidml at dts dot mg | Date: | Tue, 05 Sep 2000 14:59:53 +0000 |
| Subject: | PHP 4.0 Bug #6556: Apache can't start with pdflib support | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-32189@lists.php.net to get a copy of this message | ||
From: saidml@dts.mg
Operating system: RedHat 6.1
PHP version: 4.0.1pl2
PHP Bug Type: Installation problem
Bug description: Apache can't start with pdflib support
Hi,
I compile PHP with this options :
./configure --with-apxs=/usr/sbin/apxs \
--with-oci8 \
--with-mysql=/usr \
--with-config-file-path=/etc/httpd/conf \
--with-pgsql=/usr \
--with-gd \
--enable-ftp \
--with-imap \
--with-pdflib \
--with-openssl \
--with-zlib \
--enable-sockets \
--enable-track-vars
no error from compile.
Versions :
Apache 1.3.12 + mod_ssl 2.6.4
Oracle: 8.0.5
PdfLib: 3.02
imap : 4.7c
Mysql : 3.22.32
Postgresql : 6.5.3
When I start apache (apachectl startssl) , I've got in the apache error log :
PHP warning : Function registration failed - duplicate name - pdf_open_memory_image in Unknown on
line 0
PHP warning: imap : Unable to register functions, unable to load in Unknown on line 0
And Apache can't start.
Thanks