PHP 4.0 Bug #6567: unable to run any php in solaris 8
| From: | billie at i-cable dot com | Date: | Wed, 06 Sep 2000 05:42:34 +0000 |
| Subject: | PHP 4.0 Bug #6567: unable to run any php in solaris 8 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-32302@lists.php.net to get a copy of this message | ||
From: billie@i-cable.com
Operating system: solaris 8
PHP version: 4.0.2
PHP Bug Type: Apache related
Bug description: unable to run any php in solaris 8
i compiled php3 and php4 in solaris 8 with this parameters:
--with-mysql=/usr/local/mysql
--with-gd=/usr/local
--with-apxs=/usr/local/apache/bin/apxs
--enable-versioning
--enable-track-vars
--with-xml
then it gives "libphp3.so" and "libphp4.so" respectively. this is fine. but when
i start httpd of apache, it says it's unable to start because libphp3.so or libphp4.so has
symbolic reference error.
note: my apache1.3.12 was compiled with DSO support and SSL.
if i copied working libphp3.so or libphp4.so from a solaris 7 (i successfully run it on solaris 7),
it works. but the info is of course recorded those compiled on solaris 7 only.
so, is there any document or successful examples to compile php on solaris 8?