PHP 4.0 Bug #5665 Updated: Oracle error

From: Date: Wed, 06 Sep 2000 20:32:14 +0000
Subject: PHP 4.0 Bug #5665 Updated: Oracle error
Groups: php.dev 
Request: Send a blank email to php-dev+get-32447@lists.php.net to get a copy of this message
ID: 5665 Updated by: sniper Reported By: mark.faine@msfc.nasa.gov Status: Closed Bug Type: Oracle related Assigned To: Comments: Feedback: ----------- >Nope, as far as I know it has all the experts stumped. > >I've been over it a hundred times and can't figure it out. If you have any >more questions about it I'd be glad to answer them. ----------- Well, the problem is in the Oracle libraries, not in PHP so I will close this bug report. But if you find that this is not the case feel free to reopen this. I base my assumption to the fact that myself and other's are able to compile and run php4 and do not get this error. Ask Oracle helpdesk (or whatever it's called) for more help. And if you get this solved, please add some info here too? --Jani Previous Comments: [2000-09-06 13:44:24] sniper@php.net What is the status with this? Is it fixed? --Jani --------------------------------------------------------------------------- [2000-08-23 20:06:25] sniper@php.net Answer: The symbol "opinit" is missing from Oracle's libclntsh.so.1.0 file. Check to see if $ORACLE_HOME/bin/genclntsh has "opinit". If not, add "opinit" before the string "orlon", save the original libclntsh.so.1.0, and run "genclntsh" which will regenerate the libclntsh.so.1.0 to include "opinit". -- This was a quick google search result. Url below: http://help.netscape.com/kb/corporate/19990108-49.html Try it out. It should fix this problem. --Jani --------------------------------------------------------------------------- [2000-08-23 19:23:44] sniper@php.net Feedback: -------- Configure line follows ./configure --with-nsapi=/home/web_server/netscape/suitespot --with-oracle=/home1/app/oracle/product/732 --enable-sigchild --enable-libgcc --enable-magic-quotes --enable-track-vars --enable-trans-sid --with-openssl --disable-debug --enable-calendar --without-mysql --enable-ftp --with-gnu-ld Just for the record here is the output of ldd also: starbase# ldd libphp4.so libpam.so.1 => /usr/dt/lib/libpam.so.1 libstdc++.so.2.10.0 => /usr/local/lib/libstdc++.so.2.10.0 libdl.so.1 => /lib/libdl.so.1 libclntsh.so.1.0 => /home1/app/oracle/product/732/lib/libclntsh.so. 1.0 libm.so.1 => /lib/libm.so.1 libnsl.so.1 => /lib/libnsl.so.1 libsocket.so.1 => /lib/libsocket.so.1 libresolv.so.2 => /lib/libresolv.so.2 libc.so.1 => /lib/libc.so.1 libmp.so.2 => /lib/libmp.so.2 I've been playing a lot with the configure line and also with my LD_LIBRARY_PATH, and other environment settings trying to be sure that this is not the cause. --------------------------------------------------------------------------- [2000-08-23 05:39:51] sniper@php.net Please attach your configure line here. --Jani --------------------------------------------------------------------------- [2000-07-24 12:44:01] hholzgra@cvs.php.net type changed to oracle --------------------------------------------------------------------------- [2000-07-18 13:09:14] mark.faine@msfc.nasa.gov If I compile NES without Oracle then it works just fine but if I compile it with Oracle then I get an error when starting the server: referenced symbol: opinit not found. I assume this must be from some oracle library. The Oracle version is 7.3 Thanks Mark --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=5665

« previous php.dev (#32447) next »