PHP 4.0 Bug #6567 Updated: unable to run any php in solaris 8
| From: | Bug Database | Date: | Fri, 08 Sep 2000 17:50:56 +0000 |
| Subject: | PHP 4.0 Bug #6567 Updated: unable to run any php in solaris 8 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-32696@lists.php.net to get a copy of this message | ||
ID: 6567
User Update by: billie@i-cable.com
Status: Feedback
Bug Type: Apache related
Description: unable to run any php in solaris 8
here's the parameters to compile apache:
./configure --prefix=/usr/local/apache --enable-shared=max \
--enable-module=ssl --enable-module=most
here's the parameters to compile php3:
./configure --with-mysql=/usr/local/mysql \
--with-apxs=/usr/local/apache/bin/apxs \
--with-gd=/usr/local --enable-versioning --enable-track-vars --with-xml
here's the log after i compiled php3 successfully and run apache:
Syntax error on line 238 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1: /usr/local/apache/bin/httpd:
fatal: relocation error: file /usr/local/apache/libexec/libphp3.so: symbol mysql_free_result:
referenced symbol not found
/usr/local/apache/bin/apachectl start: httpd could not be started
i am using DSO, but the libphp3.so is never working. the same to php3 and php4.
Previous Comments:
---------------------------------------------------------------------------
[2000-09-06 05:32:47] sniper@php.net
Are you using gcc ?
Please include the whole error text here.
--Jani
p.s .I have working Apache1.3.12+php4.0.3-dev compiled on solaris 8
using gcc-2.95.2 and with almost same parameters as you.
I don't try to run both php3 and php4 concurrently so I have
left that --enable-versioning out. And we don't use SSL in that
system.
---------------------------------------------------------------------------
[2000-09-06 01:42:34] billie@i-cable.com
i compiled php3 and php4 in solaris 8 with this parameters:
--with-mysql=/usr/local/mysql
--with-gd=/usr/local
--with-apxs=/usr/local/apache/bin/apxs
--enable-versioning
--enable-track-vars
--with-xml
then it gives "libphp3.so" and "libphp4.so" respectively. this is fine. but when
i start httpd of apache, it says it's unable to start because libphp3.so or libphp4.so has
symbolic reference error.
note: my apache1.3.12 was compiled with DSO support and SSL.
if i copied working libphp3.so or libphp4.so from a solaris 7 (i successfully run it on solaris 7),
it works. but the info is of course recorded those compiled on solaris 7 only.
so, is there any document or successful examples to compile php on solaris 8?
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=6567