PHP 4.0 Bug #5773 Updated: ISAPI filter won't function with long directory name

From: Date: Fri, 08 Sep 2000 18:41:18 +0000
Subject: PHP 4.0 Bug #5773 Updated: ISAPI filter won't function with long directory name
Groups: php.dev 
Request: Send a blank email to php-dev+get-32710@lists.php.net to get a copy of this message
ID: 5773 User Update by: steve@teamITS.com Status: Feedback Old-Bug Type: Installation problem Bug Type: *General Issues Description: ISAPI filter won't function with long directory name Yes, the same symptoms occur under Windows NT 4.0 / IIS 4.0. The CGI module still loads. Previous Comments: --------------------------------------------------------------------------- [2000-09-04 20:15:38] sniper@php.net Does this problem still exist with php4.0.2 ? --Jani --------------------------------------------------------------------------- [2000-07-25 03:15:12] steve@teamITS.com Update: the ISAPI filter works under Windows 98 SE / PWS 4.0 in a long filename directory path. --------------------------------------------------------------------------- [2000-07-25 00:58:43] steve@teamITS.com If the PHP files are copied to a folder such as "D:Program FilesPHP" the ISAPI filter will not load. After copying the files to "D:inetsrvPHP" it loads. During the error condition the server returns error 500 (internal server error) for PHP pages. The CGI module loads both ways, with the long name in the configuration field as: "D:Program FilesPHPphp.exe" %s %s (however using quotes doesn't work for ISAPI...in fact without them MMC won't let you exit the dialog, claiming an invalid path). --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=5773

« previous php.dev (#32710) next »