PHP 4.0 Bug #6699: relocation error: symbol not found in libphp4.so

From: Date: Wed, 13 Sep 2000 01:57:11 +0000
Subject: PHP 4.0 Bug #6699: relocation error: symbol not found in libphp4.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-33056@lists.php.net to get a copy of this message
From: LCattaneo@mondo.it Operating system: Solaris 2.5 PHP version: 4.0.2 PHP Bug Type: Apache related Bug description: relocation error: symbol not found in libphp4.so Hi ! I'm try to work with Php 4.0.2, but .... I have a Sun Sparc Station 20, Sun Solaris 2.5, Apache 1.3.3 I created Apache with the follows steps: # ./configure --prefix=/usr/local/apache_1.3.3 --with-perl=/usr/local/bin --enable-module=so --enable-module=info # make # make install and OK . Apache works well. I created Php with the follows steps: # ./configure --prefix=/usr/local/php_4.0 --with-msql --with-apxs=/opt/apache_httpd/sbin/apxs --enable-versioning # make # make install and OK. But when I try to restart Apache with libphp4.so library, I have this result : # ./sbin/apachectl restart /opt/apache_httpd/sbin/apachectl restart: configuration broken, ignoring restart /opt/apache_httpd/sbin/apachectl restart: (run 'apachectl configtest' for details) # # ./sbin/apachectl configtest Syntax error on line 26 of /usr/local/apache_1.3.3/etc/httpd.conf: Cannot load /opt/apache_httpd/libexec/libphp4.so into server: ld.so.1: /opt/apache_httpd/sbin/httpd: fatal: relocation error: symbol not found: __udivdi3: referenced in /opt/apache_httpd/libexec/libphp4.so # You can help me ? Thank you for your time Cattaneo Luigi mail://LCattaneo@mondo.it tel: +39 125 637999

« previous php.dev (#33056) next »