PHP 4.0 Bug #7016: Error when starting iPlanet

From: Date: Wed, 04 Oct 2000 16:41:54 +0000
Subject: PHP 4.0 Bug #7016: Error when starting iPlanet
Groups: php.dev 
Request: Send a blank email to php-dev+get-34214@lists.php.net to get a copy of this message
From: lester@i-quest.com Operating system: Solaris 7 PHP version: 4.0.2 PHP Bug Type: *General Issues Bug description: Error when starting iPlanet This is the error I got when restarting iPlanet via command line after installing PHP4 w/o any errors showing up: conf_init: Error running init function load-modules: dlopen of /usr/netscape/server/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: relocation error: file /usr/netscape/server/bin/libphp4.so: symbol __pure_virtual: referenced symbol not found) Can you give me an ideas on what's going on here? Thanks. ======================================================================== We're using the GCC2.95.2 also. After configure, make and make install, these are the steps I did: 1. add the ff line in mime.types type=magnus-internal/x-httpd-php exts=php 2. edit obj.conf # note place following two lines after mime types init! Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/usr/netscape/server/bin/libphp4.so" Init fn=php4_init errorString="Failed to initialize PHP!" <Object name="default"> . . . # NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines Service fn="php4_execute" type="magnus-internal/x-httpd-php" . . </Object> <Object name="x-httpd-php"> ObjectType fn="force-type" type="magnus-internal/x-httpd-php" Service fn=php4_execute </Object> Are these correct? Thanks, Lester

« previous php.dev (#34214) next »