PHP 4.0 Bug #7266 Updated: /etc/httpd/modules/libphp4.so: undefined symbol: uncompress

From: Date: Tue, 17 Oct 2000 18:57:08 +0000
Subject: PHP 4.0 Bug #7266 Updated: /etc/httpd/modules/libphp4.so: undefined symbol: uncompress
Groups: php.dev 
Request: Send a blank email to php-dev+get-35313@lists.php.net to get a copy of this message
ID: 7266 User Update by: aryn@email.com Status: Open Bug Type: Apache related Description: /etc/httpd/modules/libphp4.so: undefined symbol: uncompress i installed the RPM -- force of php-3.0.15-2.i386.rpm, and it installed fine. then i rebuilt the latest version. (php-4.0.3pl1.tar.gz) with the ./cvsclean and ./buildconf before i build it. then i did a make clean, make, and make install. now, when starting the server, it starts fine, but will not connect on port 80. the tail of the error.log file gives: PHP Warning: Function registration failed - duplicate name - define in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - defined in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - each in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - strlen in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - strcmp in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - strcasecmp in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - error_reporting in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - leak in Unknown on line 0 PHP Warning: Function registration failed - duplicate name - function_exists in Unknown on line 0 PHP Warning: Basic Functions: Unable to register functions, unable to load in Unknown on line 0 Previous Comments: --------------------------------------------------------------------------- [2000-10-16 22:38:16] aryn@email.com i get this error with versions 4.0.2 and 4.0.3pl1, and i can't seem to figure out why it's doing this. when i try to restart apache, i get: Starting httpd: Syntax error on line 132 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: uncompress [FAILED] any help? version: php4.0.2 OS: redhat6.2 configure line: ./configure --with-mysql=/www/mysql --with-pgsql=/www/pgsql --with-apxs=/usr/sbin/apxs --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7266

« previous php.dev (#35313) next »