PHP 4.0 Bug #7309 Updated: configure fails on apxs, even though it's correct
| From: | sniper@php.net | Date: | Fri, 20 Oct 2000 14:37:32 +0000 |
| Subject: | PHP 4.0 Bug #7309 Updated: configure fails on apxs, even though it's correct | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-35661@lists.php.net to get a copy of this message | ||
ID: 7309
Updated by: sniper
Reported By: vegard@svanberg.no
Status: Closed
Bug Type: *Install and Config
Assigned To:
Comments:
User reported problem solved with Rasmus's advice..
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2000-10-19 19:05:48] rasmus@php.net
This usually happens when you have an Apache instance that was not built with --enable-module=so
---------------------------------------------------------------------------
[2000-10-19 19:02:43] sniper@php.net
Try running apxs 'by hand':
/usr/local/apache/bin/apxs -q CFLAGS
You are using apache installed from rpm ?
Have you tried to compile it yourself from sources??
--Jani
---------------------------------------------------------------------------
[2000-10-18 08:14:01] vegard@svanberg.no
Hi.
I'm running Apache 1.3.14. When I try to configure php, I get this
error;
# ./configure --with-apxs=/usr/local/apache/bin/apxs
[............]
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache module support via DSO through APXS...
Usage: apxs -g [-S <var>=<val>] -n <modname>
apxs -q [-S <var>=<val>] <query> ...
apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
[-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
[-Wl,<flags>] <files> ...
apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Sorry, I cannot run apxs. Either you need to install Perl or you need to pass the
absolute path of apxs by using --with-apxs=/absolute/path/to/apxs
#
I _have_ specified apxs' location and I _have_ perl installed and I can't think of this of
any other way than a bug.. I've also moved RHs buggy apxs out of the way. What's going
on?
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=7309